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Introduction
Capstone is an HPCMP CREATE™-MG product. This tutorial was generated by
the HPCMP CREATE™-AV Quality Assurance team, with specific intentions of
being applied to AV-related cases, however, it could be applicable in other areas as
well.

Why this Tutorial?

Objectives:
Gain familiarity with importing text files
Explore basic geometry generation techniques

Potential Applications:
Simple geometry creations
3D Wing, Symmetry Planes

Notes Going Forward:

Bold Font indicates a menu or shortcut button option

> indicates a sub selection

Blue text indicates options/selections inside of an operation or function

This tutorial assumes you know some basic Capstone operations. If you need
an introduction please watch the Capstone Intro Video (˜15 min) found here

Distribution A: Approved for public release; distribution is unlimited. 4

https://wiki.create.hpc.mil/confluence/display/MG/V7.1+Documentations


Topology Definitions
Capstone uses the following Topology model to describe geometry:

Model

Total grouping of all Breps
and meshes

Brep (Boundary Representation)

A grouping of geometry
entities

Region

A water-tight volume defined
by connecting faces where the
volume mesh will be generated

Face

Surface defined by a closed set
of edges

Edge

Curve bounded by 2 (or 1 if
self looping) vertices

Vertex

Point defined by x,y,z location
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Workflow

1. Geometry Setup

Import or create geometry

Can be CAD or Discrete

If CAD, then “clean” to make water-tight

utilize the Edit > Basic Cleanup menu

Fluid Volume Region Creation

Regions are where the volume mesh will be created
Define the fluid volume to be solved on

2. Mesh Set-up

Set Analysis

Work your way down the Attributes Tab

For example, set up Global Sizing, Topos Sizing, Boundary Layers, Periodicity
and any other mesh settings as desired

Set up both Surface and Volume mesh settings before meshing for highest
mesh quality/consistency
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Workflow Continued

3. Generate Meshes

Generate a Surface Mesh

Inspect the mesh (visually and/or using Mesh > Mesh diagnostics or Detect
defects and heal) and make any necessary changes

Generate a Volume Mesh
Inspect the mesh again

Utilize Mesh > Mesh crinkled cutplanes to visualize the volume cells

4. Export Mesh

Create mesh Properties (like Patches) if desired

File > Export Mesh
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Importing Airfoil Coordinates

Open Capstone and ensure you are in SMLIB mode: Config/Help > Switch
Geometry Kernel to SMLIB

Vertices > Vertices/Edges Extraction From Text File and hit Load

Locate airfoil.txt then click Open

Click on the left column, then right-click and select Set Column as X
Coordinate

Click on the right column, then right-click and select Set Column as Y
Coordinate

Hit Next
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Airfoil creation
Select all the coordinates by pressing and holding LMB and dragging to the
bottom

Select Interpolated NURBS and hit Create From Selection then exit the menu

Now Edit > Copy Topologies select Rotation and Copy in Same Brep and
enter 180 deg.

Select the airfoil edge and hit Apply, then exit the menu
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Airfoil Completion
At this point you can inspect the airfoil and notice that there are 2 vertices
overlapped at the leading edge (LE) and that the trailing edge (TE) is blunt and
currently not connected. Let’s take care of these:

Edit > Stitch Topos

Select both of the LE vertices, and hit Apply

Edges > Edge Creation from Points, select the 2 TE vertices and hit Apply

Now is a good time to save your model. Use File > Save-As Create-Native
Dataset which will save the file as NAME.cre

Distribution A: Approved for public release; distribution is unlimited. 11



Scaling

The ONERA M6 wing has specific geometry, described by NASA here, therefore,
we must now scale our airfoil and create the rest of the geometry necessary to
complete the wing.

Edit > Move Selected Topologies, select Scaling and the entire airfoil,
then enter .8059 for all 3 Scaling Ratios and hit Apply
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http://www.grc.nasa.gov/WWW/wind/valid/m6wing/m6wing.html


Tip Airfoil Creation
Create the tip airfoil by copying the root airfoil and scaling/moving it to be the
correct size/location.

Edit > Copy Topologies, Scaling and enter .562 for all 3 Scaling Ratios

Select the airfoil and Copy in Same Brep, then hit Apply

Edit > Move Selected Topologies, Translation, and enter .690656, 0,
1.1963

Select the tip (small) airfoil and Move Only Selection, then hit Apply
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Wing Tip Creation
Now we need to cap-off the end of the wing tip with a rounded face.

Advanced > Extrusion and
select Rotation

Set Axis to 1,0,0

Set Origin to .690656, 0,
1.1963

Set Angle to 180

Select the top edge of the tip
airfoil and hit Apply

The extrusion has created duplicate edges on the tip airfoil.
To delete the unused tip edges, navigate to the Explorer Tab and uncheck
Show Only Selection. Right-click Brep 2 and select Hide. (Edges and vertices
associated with Brep 2 are now greyed out in the Explorer Tab.)
Holding the Shift key, drag a box around the entire tip airfoil to select all of
its topologies and hit Edit > Delete all selected topologies
Lastly, hit the Show All button to bring the hidden geometry back
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Merge Breps and Connecting Edges
The new wing tip we just created was placed into a separate Brep. We need to
merge the two before we can complete the wing shape by adding the leading and
trailing edges.

Use Shift and drag the LMB to
select all of the topologies

Breps > Merge the selected
breps into a single brep or hit the
button shown on the right

Edges > Edge Creation
from Points

Select the 2 vertices
forming the LE and hit
Apply

Repeat for the 2 TE lines

Lastly, connect the upper
and lower vertices on the
wing tip with a vertical
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Wing Surface Creation
Now we can complete our wing by creating the final faces.

Faces > Face Creation from Edges and select the 4 edges that make up
the upper surface of the wing. Then hit Apply

Repeat for the lower surface of the wing, TE, and TE-tip faces

If the TE-tip face (shown above) fails or doesn’t give you the option to hit apply,
then check the next slide for a workaround
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Planar Face Creation - Workaround

Sometimes faces will fail to create (planar or otherwise) if Capstone can’t make
sense of the underlying edges being used. Normally, a great workaround for this
type of issue is to split the geometry edges into smaller chunks. So for a circle,
rather than using 1 complete circular edge, we could split it into 4. For this
example, since we only need half a circle we will split the edge in half.

Edges > Split Edge at Edge Parameter and select the curved edge of the
tip face. Split it at .5 and try creating the face using the 3 curves. This
should allow the option of a BGN 3-sided Coon patch.
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Region Creation

First, finish closing off the wing by creating a face on the root airfoil.

Faces > Face Creation from Edges and select 1 airfoil edge at the root (it
should auto-complete the rest) and hit Apply

Your wing is now complete! Save your progress. The wing is now water-tight (you
can verify this by going to Edit > Basic Cleanup and looking at the Closure
section) and a Region was automatically created on it. Now let’s create an outer
boundary box for the fluid region.

Solids > Primitives Creation and select the
Rectangular Prism option

Set Center to 0, 0, 6

Set Dimensions to 24, 24, 12

Ensure Create Solid is selected and hit Apply

You now have 2 Breps and 2 Regions that need to be Boolean Differenced for the
final fluid volume to be created.
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Fluid Volume

The regions that have been created are internal to their respective geometry
boundaries. Therefore, the region inside of the wing needs to be subtracted from
the region inside of the box for the fluid volume region to be correct.

Breps > Boolean Operations

Select Difference

Select the box then hit >>

Note, it is important to select
the box first, because
Difference will subtract the
second selection from the first!

Select the wing and hit Apply

Congratulations, you have completed setting up the geometry! Save your progress.
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Curvature-Based Surface Mesh
For a quick and easy surface mesh use the auto sizing and curvature-based sizing.

Set the Analysis to Kestrel

Attributes Tab > Meshing >
Global Sizing

Hit OK to accept the auto
sizing ratio

Check Curvature-Based Sizing
and hit Apply

Select MESHER C1 from the
Mesher drop down menu at the
bottom of the Attributes tab

Select Mesh > Generate Face
Mesh and the surface mesh will
automatically start generating

After mesh is complete, hit
Show tessellation
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Volume Meshing

Now we are ready to complete an Euler volume mesh.

With MESHER C1 still selected
in the Mesher drop down, select
Mesh > Generate Region
Mesh

The volume mesh will
automatically start generating
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Crinkle Cuts

After the mesh is complete, look at it!

Mesh > Mesh crinkled cutplanes

Set Point to .58, 0, 6 (or move the slider)

Hit Calculate

Play around with different views to inspect the mesh
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Mesh Manager

To gather data about the mesh use the Mesh Manager.

File > Manage Geometry/Mesh
Models

The pyramid next to Mesh 2
indicates a volume mesh

Highlight Mesh 2 and the right side
of the menu displays the
information on the number of cells

Faces on “Geometry Faces”
indicate surface cells

Regions indicate volume cells

Rename Mesh 2 to VolumeMesh
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Mesh Diagnostics
Two menus that are helpful tools for diagnostics are:

Mesh > Mesh diagnostics

Select the Volume Quality Check tab
and select VolumeMesh as your Model

Mesh > Detect defects and heal

Check the box under Shape & Quality

Hit Detect

Notice the cells are colored based on
what diagnostic they failed

If a threshold is too sensitive (like
Face Area in this case) simply change
the value in the white box

Also, keep in mind that this mesh is very coarse and setup only for the purpose of
this tutorial. A much more detailed/finer mesh would be needed for CFD analysis.
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Patch Creation
Now, we want to create patches for a Kestrel simulation.

Attributes Tab > Properties > Patches

Right-click Patches and hit Create a new group

Specify the patch type from the drop-down bar

Name the patch “Wing” by typing in the text field labeled ”Name”

Select the 5 wing faces, then right-click the new “Wing” patch and hit Add
Topos

Repeat the process for the Far-field (5 faces) and Symmetry Plane (1 face)

Note that you can select the faces first before creating a new group and the
selected faces will be put into it.
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Export Mesh

Now you are ready to export your mesh. Save the cre file one more time before
you export the mesh.

File > Export Mesh

Verify the Format is set to Kestrel Exporter (avm)

Verify the mesh is on “VolumeMesh” (If not, then exit the menu and switch
to your volume mesh using the Mesh Model drop-down menu.)

Browse to select a file location and name and hit OK
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Conclusion

You have now completed the Capstone portion of creating your grid.

For more help relating to Capstone or other CREATE products please check out:

Capstone Website
Capstone User Online Forum
CREATE Website
CREATE-MG Quality Assurance Support
CREATE-AV Quality Assurance Support
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