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DoD

Introduction

Capstone is an HPCMP CREATE"-MG product. This tutorial was generated by
the HPCMP CREATE™-AV Quality Assurance team, with specific intentions of
being applied to AV-related cases, however, it could be applicable in other areas as

well.

Why this Tutorial?
@ Objectives:
e Gain familiarity with various features/functions inside of Capstone
e Practice cleaning up “dirty” CAD
@ Potential Applications:
o CAD cleanup

Notes Going Forward:

@ This tutorial assumes you have completed introductory training either
through the Intro Video or Workflow Intro (In the AVQA Section) tutorial

o If you have not, please check out the latest Documentation page to
download the video/tutorial

Distribution A: Approved for public release; distribution is unlimited.


https://wiki.create.hpc.mil/confluence/display/MG/V6.2.0+Documentations

Topology Definitions

Capstone uses the following Topology model to describe geometry:
Region

Face

Model
Brep

Edge
Vertex

Model

o Total grouping of all Breps
and meshes

Brep (Boundary Representation)
@ A grouping of geometry

Face
@ Surface defined by a closed set
of edges
Edge
o Curve bounded by 2 (or 1 if

entities
Region self looping) vertices
o A water-tight volume defined ~ Vertex
by connecting faces where the @ Point defined by x,y,z location

volume mesh will be generated
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Workflow HPC

1. Geometry Setup
@ Import or create geometry
e Can be CAD or Discrete
o If CAD, then “clean” to make water-tight
o utilize the Edit > Basic Cleanup menu
@ Fluid Volume Region Creation

e Regions are where the volume mesh will be created
o Define the fluid volume to be solved on

2. Mesh Setup
@ Set Analysis if not already defaulted (can set in File > Preferences)

@ Work your way down the Attributes Tab

e For example, set up Global Sizing, Topos Sizing, Boundary Layers, Periodicity
and any other mesh settings as desired

@ Set up both Surface and Volume mesh settings before meshing for highest
mesh quality/consistency
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Workflow Continued

3. Generate Meshes
@ Generate a Surface Mesh

o Inspect the mesh (visually and/or using Mesh > Mesh diagnostics or Detect
defects and heal) and make any necessary changes

o Generate a Volume Mesh
@ Inspect the mesh again
@ Utilize Mesh > Mesh crinkled cutplanes to visualize the volume cells

4. Export Mesh
@ Create mesh Properties (like Patches) if desired
o File > Export Mesh

Distribution A: Approved for public release; distribution is unlimited. 7
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Helpful Functions Overview HeC ©

There are many cleanup functions in Capstone. For your reference, here are brief
summaries for some of the most helpful ones:
Edit > Stitch Topos and Breps > Stitch Brep
@ Used to merge common entities that are duplicated
@ Example: When two faces share a common geometric edge, but topologically
there are 2 edges between them. Use these functions to stitch them into one,
making the connection between the faces “water-tight”
@ Stitch Topos is used on individual entities the user selects, Stitch Brep
applies a generic stitching routine to the entire Brep
Faces > Untrimmed (or Trimmed) Face Creation
@ Used to untrim a surface beyond its existing edges, or trim a face using a set
of existing edges
Edges > Merge Connected Edges
@ Used to combine 2 connecting edges, that share only 1 vertex, into 1 edge.
Faces > Join Faces
@ Used to combine 2 adjacent faces into 1 face. Works best if only 1 edge is
shared.
Faces > U/V Face Split
@ Used to split a face in U/V coordinate space.
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Water-tight Geometry

The following slides will discuss various (but not all) ways to use Capstone to get
surfaces to intersect properly so they can be water-tight when they have shared
edges geometrically but not topologically. Meaning, there are duplicate edges that
share the same geometric (xyz) space, but each edge is only associated
topologically with one of the adjacent faces.

The best option for cleaning this up is Edit > Stitch Topos. It is the most robust
and gives the user the most control. For Stitch Topos to work on edges keep in
mind that the edges must share the same vertices. So you may need to stitch the
duplicate vertices first.

Another option you can try is Brep > Stitch Brep. This does what Stitch Topos
does, but on a global level (the entire Brep not just the individual edges/vertices
you select). This one can be dangerous as the results aren't always as desired, but
it is worth trying if you have a large number of merges required.

The last option we'll discuss is utilizing the Faces > Trimmed (or Untrimmed)
Face Creation functions that Capstone provides. This option works fairly
robustly, but requires a few extra steps/clicks.

Distribution A: Approved for public release; distribution is unlimited.
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Stitch Topos HPC

geometrically. Load trimming.cre and use Stitch Topos to make it water-tight.

@ Switch to Display Type > Usage

@ The yellow edges indicate “Edges Used
Once” and if you were to try to select
them you would get the drop-down
indicating you have two choices in the
same geometric location

e Edit > Stitch Topos and rubber-band
select the area where the 2 edges are
overlapping (and yellow) on the “top”
face, then hit Apply

@ This will combine the extra edges and leave you with just 1 edge per side!

o If you are not happy with the results, or need finer control, you can manually
select 2 topologies at a time and stitch them individually

@ This will give you a water-tight sphere!; Any time sucessful merging/stitching
occurs Capstone automatically attempts to create Regions on closed
geometry
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Stitch Brep HPC

Stitch Brep can be used to allow the code to search the Brep for overlapping
edges/vertices and stitch them automatically. This option is very helpful if a large
number of items need to be stitched, however, it can also stitch things that you
may not have wanted to, so use it carefully!

Re-load trimming.cre for an example of how to use Stitch Brep.

o Breps > Stitch Brep
@ Select the Brep and hit apply

@ You now have a water-tight geometry and
a region was automatically generated!
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Untrimmed Face Creation

To practice this function, re-load trimming.cre

@ Switching to Display Type > Usage
shows the “top” face isn't connected to
the rest of the sphere

e Faces > Untrimmed Face Creation.
Select the “top” (Face 5), then hit Apply

o Edit > Delete Topologies, Select the
original "top” (Face 5), hit Lower Entities
then hit Apply (This will delete the face,
and the edges/vertices associated with it)

The next slide will show you how to trim the face to make a water-tight region.
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Trimmed Face Creation

e Faces > Trimmed Face Creation. Check
Delete the Original Face if Permitted,
select the new face (Face 3) and Edges 5
and 6 (it should auto-complete once one
edge is selected), then hit Apply

Notice that the “original face” (Face 3) wasn't deleted, despite the option we
checked. This is because a region was automatically created during the trimming
process that included this face! But why, since it isn’t topologically connected?!

Anytime a trim, stitch, or merge occurs Capstone automatically attempts to
create a region when a set of topologically connected faces, all in the same Brep,
encloses a closed finite volume. Any topologically unconnected geometry that is
fully contained within the closed volume and that is part of the same Brep will be
embedded in the Region!

In this case, the trimming created a fully topolocially connected sphere, and the
original face (Face 3) is still in the same Brep and “fully contained” within the
closed volume of the topologically connected sphere, therefore it got added to the
Region...and this brings us to our next lesson: How to Delete Topologies

Distribution A: Approved for public release; distribution is unlimited. 14
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How to Delete Topologies HPC

nnnnnnnnnnnnnnnnnn

Topologies can only be deleted if they are NOT used by higher level entities:
Faces cannot be deleted that are used by a Region. Edges cannot be deleted that
are used by a Face or a Region. Vertices cannot be deleted that are used by an
Edge, a Face or a Region.

So, to delete the unwanted Face 3, we must also delete the region that it is
associated with. (Don't forget, you can always use the Explorer Tab to right-click
“Select Up or Down" to select/view the connections, or simply highlight and view
the connections in the Adjacencies Panel)

o Edit > Delete Topologies.
Select Face 3, then hit Upper
Entities and then hit Apply

15
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Delete Unused and Region Creation

o Edit > Delete Topologies.
hit Unused Vertices and
Edges and then hit Apply

@ This deletes the remaining
edges/vertices that were part
of Face 3

@ Solids > Region Creation
from Faces, select any face
of the sphere and hit Apply

@ You now have a water-tight
sphere!

Distribution A: Approved for public release; distribution is unlimited. 16
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Merge Connected Edges

To practice this function, load merging.cre

o Edges > Merge Connected Edges
@ Select the 2 adjacent edges you wish to
merge and hit apply

@ It is best to start with the largest and work
your way towards the smallest edge

o Alternatively, if the edges are linear or
perfectly tangential, you can select all of
them at once and merge them in one step

@ Repeat the process until you only have 1
edge between the two adjacent faces

@ If joining the faces, having only 1 edge
between them is the most robust way of
doing so, hence why we merged the edges

Distribution A: Approved for public release; distribution is unlimited. 17



Join Faces

To practice this function, you can either start from where you left off with Merge
Connected Edges or you can start from scratch with merging.cre again.

The instructions below will work in either case. This geometry is simple enough
that the edges between the faces did not need to be merged as shown on the
previous slide for the joining to work properly.

o Faces > Join Faces
@ Select the 2 faces and hit apply

@ The final result will be one face

18
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U/V Face Split

This function can be used to split a face along a desired U/V parametric line of
the geometry. Continue on with the geometry from the previous slide, after the
faces have been joined.

e Faces > U/V Face Split
@ Select the face and notice the preview line

@ Switch to U direction

@ Set the probe to

@ You can change where the cut will be by coordinates and probe

moving the slider, entering a manual U/V select (Ctrl or Alt

Parameter, or using the probe +LMB) the vertex
@ For this case, we will use the existing shown below

vertex on the left edge and the probe to o Hit Apply

do the cut
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When Stitching/Merging Fails

Here is a checklist for when Stitching/Merging or any other operations fail:

@ Are the geometry entities in the same Brep?

e This is required for non-Boolean Operations
e To fix this, utilize Boolean Union/Non-Regularized Union, or Merge Breps

@ Does a Region exist?
e Edges/Vertices cannot be Stitched with Edges/Vertices that are part of an
existing Region
e Delete the Region and try the stitch/merge again
© Does a set of topologically connected faces enclosing a finite volume exist?
e Normally this only occurs if you previously had a Region, but deleted it
e The same problem as number 2, above, is occuring, because as the
stitch/merge is attempted Capstone is automatically creating a region on the
topologically connected faces and then it is failing to merge/stitch because of
the “existing” Region (even though the Explorer Panel shows 0 Regions)
o To fix this, delete a face (that will be easily re-created) that is part of the
topologically connected set, thus removing any/all topologically connected
finite volumes. (Most likely this will be an outer boundary box face.)
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When Stitching/Merging Fails (continued) Epg

nnnnnnnnnnnnnnnn

© Are outer box/farfield faces present in the same Brep?

e In many operations including stitching, the SMLib geometry kernel attempts
to create a region, but it gets confused if the faces in the Brep are
non-manifold (not all topologically connected). This can cause the operation
to fail without any indication of what went wrong. The solution is to delete
the outer faces or split them into a separate Brep.

21
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Geometry Provided

The “dirty” CAD file is provided (originally an iges file) as dirtyCAD.cre. Load the
file into Capstone. It should look like the pictures below (Display Type > Usage
on right):

The CH logo is on the “upper” surface of the airfoil (though it is symmetric)

Included with the tutorial download is an Answer Video that goes through step by
step how to complete the cleanup. Please reference it as needed if you get stuck!
There is also a cleanCAD.cre file which is the final state of the clean geometry,
including a volume mesh.
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CAD Cleanup Instructions

The following list of instructions will guide you when cleaning up the CAD
@ Make the grid xByRzU, with the root LE vertex at 0,0,0
@ Create 1 connected face across the upper surface of the wing
e Remove the CH logo
e Remove the small faces near the wing tip
e Use the functions from the previous slide as necessary
Utilize Edit > Basic Cleanup
e Remove/replace anything that fails Edge/Topos Validity
e Remove any unwanted Small Edges/Faces
e Make it watertight by monitoring the Closure or Display Type > Usage
@ Once satisfied with geometry cleanup, create a region on the wing
The final cleaned up geometry should look like this:

OGRAM
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Fluid Volume Instructions

Now that the geometry is cleaned, create an outer boundary box and the fluid
region
o Create a boundary box with a symmetry plane with dimensions:

e 10 span lengths forward and aft
e 5 span lengths to the side, up, and down

@ Create the fluid volume region

e Utilize the Breps > Boolean Operations so you end up with 1 Brep and 1
Region (the fluid volume region)

Search
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Mesh Instructions

Now that the CAD is cleaned, and the fluid volume created, it is time to create
the mesh. First, add Kestrel Analysis then size the geometry as follows:

@ The smallest outer boundary edge should have 10 cells across its length
@ Sizing on the Wing Faces of 4% of chord
@ Sizing on the Wing Tip Face of 1% of chord
@ Sizing on the Probe of 10% of its diameter
o Utilize Edge Boundary Layers

e Leading and trailing edge chord-wise spacing of .04% chord for 1st Layer
@ Utilize Face Boundary Layers

e Assume Reynolds number of 1e6, y+=1, and the chord as the reference length
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Conclusion

Congratulations on finishing your mesh! Hopefully, it looked something like the
last picture and don’t forget cleanCAD.cre is included for you to inspect and
compare.

For more help relating to Capstone or other CREATE products please check out:

Capstone Website

Capstone User Online Forum

CREATE Website

CREATE-MG Quality Assurance Support
CREATE-AV Quality Assurance Support
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